В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Говницооо
Говницооо
18.02.2022 13:03 •  Информатика

Напишите программу на языке паскаль , которая будет делииь пирог на равные части по весу. ( масса пирога/кол во учеников ) Если кол во учеников = 0 , то должно выйти сообщение " 0 учеников в классе не может быть "

Ответ:

var

 m, d :integer;

 part : double;

begin

 writeln('Масса пирога =');

 readln(m);

 writeln('количество учеников =');

 readln(d);

 if d > 0 then begin

   part := m/d;

   writeln('Вес каждой части пирога = ', part:2:2)

 end

 else

   writeln('0 учеников в классе не может быть');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?