В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости.
Пользователь вводит строку в виде <нн+н+++н+нн++н>, где <н> это пропуск, а <+> это посещения.
Программа должна вывести в качестве ответа следующую информацию:
Количество занятий N
Количество пропусков M
Пропущено X%. (Процент)

Ответ:
Evklidushka
Evklidushka
14.05.2021 12:30

N = 0

M = 0

a = input()

for i in range(len(a)):

   if a[i].lower() == 'н':

       M += 1

       N += 1

   elif a[i] == '+':

       N += 1

X = round(100 * M / N, 2)

print(f'Количество занятий: {N}',

     f'Количество пропусков: {M}', f'Пропущено {X}%', sep='\n')


Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости. Польз
Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости. Польз
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?