В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
37892
37892
25.09.2020 23:07 •  Информатика

на языке python Напишите программу, которая получает с клавиатуры два числа, одно из которых может не быть целым, и вычисляет их произведение, используя только операции сложения. Учтите, что числа могут быть отрицательными

Ответ:
gmunaitbas
gmunaitbas
10.04.2021 01:00

x=int(input())

y=int(input())

res=0

z=0

while z!=(abs(y)):

   res=res+(abs(x))

   z=z+1

if y < 0:

   res= -res

if x < 0:

   res= -res

print(res)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?