В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
azzitop
azzitop
20.10.2022 07:00 •  Информатика

инфа
Написать программу на паскаль


инфаНаписать программу на паскаль ​

Ответ:
ludmilacernakov
ludmilacernakov
08.05.2021 21:24

Задачу решил, но я ее не смог нормально протестить, но она работает и выдает правильный ответ, вечером посмотрю и если что напишу в комментариях или изменю ответ.

Объяснение:

var syt,koln,s:integer;

x:real;

napr:string;

begin

write ('Введите город (направление):');

read (napr);

writeln();

write ('Введите кол-во направлений: ');

readln (koln);

writeln();

write ('Введите кол-во cуток за который приобретается билет: ');

read(s);

if napr='Москва' then begin

if koln=1 then

x:=2500

else

x:=4200;

end;

if napr='Санкт-Петербург' then begin

if koln=1 then

x:=2300

else

x:=3700;

end;

if napr='Казань' then begin

if koln=1 then

x:=2400

else

x:=4200;

end;

if napr='Сочи' then begin

if koln=1 then

x:=3400

else

x:=5200;

end;

if syt>45 then

x:=x-(x/100*20);

if syt>20 then

x:=x-(x/100*10);

if (x=1) or (x=2) or (x=3) then

x:=x-(x/100*3);

writeln ('Cтоимость билетов на троих: ',x*3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?