В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gggggguuu
gggggguuu
24.04.2022 11:41 •  Информатика

Язык программирования С++ 9 класс Напишите программу, которая заменяет во всей строке одну последовательность
символов на другую.
Пример:
Введите строку:
(X > 0) and (Y < X) and (Z > Y) and (Z <> 5)
Что меняем: and
Чем заменить: &
Результат
(X > 0) & (Y < X) & (Z > Y) & (Z <> 5)

Ответ:
Boxing12474
Boxing12474
08.05.2021 20:27

#include <iostream>

#include <string>

using namespace std;

signed main() {

   setlocale(LC_ALL, "Rus");

   string strInput, findText, replaceText;

   size_t position = 0;

   cout << "Введите текст:" << ends;

   getline(cin, strInput);

   cout << "Введите то, что надо заменить: ";

   getline(cin, findText);

   cout << "Введите на что меняем: ";

   getline(cin, replaceText);

   string strOut = strInput;

   while ((position = strOut.find(findText, 0)) != string::npos)

   {

       strOut.replace(position, findText.size(), replaceText);

       position++;

   }

   cout << "Изменённый текст: " << strOut << endl;

   cin.get();

   return 0;

}

Либо:

#include <regex>

#include <string>

#include <iostream>

using namespace std;

int main() {

   setlocale(LC_ALL, "Rus");

   string strInput, findText, replaceText;

   cout << "Введите текст: ";

   getline(cin, strInput);

   cout << "Введите то, что надо заменить: ";

   getline(cin, findText);

   cout << "Введите на что меняем: ";

   getline(cin, replaceText);

   strInput = regex_replace(strInput, regex(findText), replaceText);

   cout << "Изменённая строка: " << strInput;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?