В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
01Таня10
01Таня10
17.05.2020 20:43 •  Информатика

СЕРЕДОВИЩЕ ВИКОНАННЯ: Pyton Створіть програму для обчислення кількості парних елементів у

списку, заповненого випадковими числами.​

Ответ:
Саша12811
Саша12811
08.05.2021 00:20

n = int(input('введите количество элементов списка '))

mass = [int(input('введите элемент списка ')) for j in range(n)]

k = 0

for i in mass:

  if i % 2 == 0:

      k += 1

print(mass)

print('Количество парных чисел ', k)

Объяснение:

from random import randint

n = int(input('введите количество элементов списка '))

mass = [randint(1, 100) for j in range(n)]

k = 0

for i in mass:

  if i % 2 == 0:

      k += 1

print(mass)

print('Количество парных чисел ', k)

0,0(0 оценок)
Ответ:
nadyushasukhan
nadyushasukhan
08.05.2021 00:20

Вариант 1, где пользователь вводит нужное количество, а числа генерируются случайно:

import random

elements = [] # создаём пустой список, куда будут записываться введенные числа

# спрашиваем пользователя сколько чисел необходимо

numbersCount = int(input('Сколько чисел желаете сгенерировать: '))

for i in range(numbersCount): # запускаем цикл столько раз, сколько запросил пользователь

   elements.append(random.randrange(1,100)) # наполняем elements случайным числом

evenNumbersCounter = 0 # счётчик чётных чисел

for element in elements:

   if element % 2 == 0:

       evenNumbersCounter += 1

print(f'Числа: {elements}')

print(f'Количество четных чисел: {evenNumbersCounter}')

Вариант 2, где пользователь сам вводит 20 чисел:

elements = [] # создаём пустой список, куда будут записываться введенные числа

# цикл 20 раз спрашивает числа у пользователя и записывает их в elements преобразовывая в int

for i in range(1,21): #

   elements.append(int(input(f'#{i} Введите число: ')))

evenNumbersCounter = 0 # создаем счётчик, куда далее будем считать количество четных чисел

for element in elements:

   if element % 2 == 0:

       evenNumbersCounter += 1

       # увеличиваем счётчик, если у числа нет остатка при делении на 2 (то есть, число чётное)

print(f'Количество четных чисел: {evenNumbersCounter}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?