В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sashacom13
sashacom13
02.12.2020 13:54 •  Информатика

Количество пятерок На вход программе подается последовательность целых чисел от 1 до 5, характеризующее оценку ученика, каждое число на отдельной строке. Концом последовательности является любое отрицательное число, либо число большее 5. Напишите программу, которая выводит количество пятерок.

Ответ:
0динокийхомяк
0динокийхомяк
06.05.2021 16:02
Python:

mark = int(input())

count = 0

if mark == 5:

       count += 1

while (mark<=5 and mark>0):

   mark = int(input())

   if mark == 5:

       count += 1

print(count)

Ввод/Вывод:

1                                                                                                                                

1                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

-1                                                                                                                              

5    

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?