В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
KARINALEMANN
KARINALEMANN
17.07.2021 01:14 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры два целых числа х и у, не равных нулю, и определяет номер координатной четверти, которой принадлежит точка
с координатами (x, y). Номер четверти выводите в римской системе счисления. Если точка
находится в первой четверти, то вывести I, если во второй - II, если в третьей - |||, если в
четвёртой - IV.
Числа вводятся в одной строке - используйте команду readln (x, y).
Указание. Программа должна выполнять минимальное число проверок для каждой пары.​

Ответ:
Kamilla1472
Kamilla1472
06.05.2021 10:14

var xy:integer; begin readln (xy); if (x>0) and (y>0) then writeln ("); if (x>0) and (y0) then writeln (IV'); (x<0) and (y>0) then writeln (' II'); if (x<0) and (y<0) then writeln ("I); end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?