В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tanyaprokudina
tanyaprokudina
04.04.2023 03:26 •  Информатика

Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наименьшая

Ответ:
dauren130
dauren130
02.05.2021 05:58

from random import randint

n, m = 5, 5

A = [[randint(1, 10) for j in range(m)] for i in range(n)]

for row in A:

 for x in row:

   print("{:4d}".format(x), end='')

 print()

b = [sum(x) for x in zip(*A)]

 

print('Суммы по столбцам')

print(b)

k = b.index(min(b))

print('Индекс столбца с наименьшей суммой : ', k)

print('----------------')

for i in range(m) :

 print(A[i][k])


Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наимен
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?