В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
simpleam
simpleam
03.05.2021 12:33 •  Информатика

Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных
Входной файл содержит число x. Считать, что вводимые значения x принадлежат области определения выражения.

Формат выходных данных
В выходной файл выведите ответ на поставленную задачу не менее чем с 4 знаками после десятичной точки.

Примеры:
Вход
1
Выход
8.4147

Ответ:
ErmolinVI
ErmolinVI
26.04.2021 12:13

Код C#:

double x;

           Console.Write("x = ");

           x = Convert.ToInt32(Console.ReadLine());

           x = 10 * Math.Sin(x) + Math.Abs(x*4-x*5);

           Console.WriteLine("Конечный результат: x = {0:0.#####}", x);

           Console.ReadKey();

Код Pascal:

Var

x:real;

Begin

Readln(x);

x := 10* Sin(x)+ abs(x*4-x*5);

write('x = ', x);

end.

Объяснение:


Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных Вход
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?