В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
likonady
likonady
09.05.2021 12:35 •  Информатика

НАПИШИТЕ ПРОГРАММУ НА C++, есть заготовка, кину в 1 комментарий A07. Серия Побед
ограничение по времени на тест1 секунда
ограничение по памяти на тест256 мегабайт
ввод стандартный ввод
вывод стандартный вывод
Вася играет в популярную командную игру Mota2. К сожалению, команда часто подводит Васю и он проигрывает некоторые матчи, несмотря на все старания. В то же время некоторые матчи Васе удается выиграть, независимо от действий его команды. Всего Вася сыграл уже N матчей в Mota2.

Вася любит статистику и следит за своими достижениями в игре. В частности, ему интересно, как много матчей подряд он уже выигрывал? Сложно ли побить его рекорд? По результатам матчей Васи нужно указать длину наибольшей победной серии — то есть наибольшее количество выигранных подряд матчей.

Входные данные
В первой строке содержится число N — количество сыгранных Васей матчей (1 ≤ N ≤ 100). Во второй строке содержится последовательность нулей и единиц — результаты матчей Васи. Выигранный матч задается единицей, проигранный — нулем.

Выходные данные
Выведите единственное число — длину наибольшей победной серии.

Примеры
входные данные
4
1 0 1 1
выходные данные
2
входные данные
3
0 0 0
выходные данные
0

Ответ:
Женечка180510
Женечка180510
24.04.2021 10:13

Объяснение:

#include <iostream>

using namespace std;

int main()

{

   int N, counter = 1, max_counter=1,post;

   cin >> N;//всего матчей

   cin >> post;// ввод первого числа последовательности  

   for (int i = 0; i < N-1; i++) {

       int a;

       cin >> a;// ввод остальных N-1 чисел последовательности

       if (a == post && a == 1) {

           counter++;

           if (counter > max_counter)

               max_counter = counter;

       }

       else

       {  

           counter = 1;

       }

       post = a;

   }

       cout << max_counter;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?