В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dcveergh
dcveergh
04.03.2021 07:12 •  Информатика

Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — разбить его на два массива, причём в первом из них будут содержаться все элементы a, стоящие на чётных позициях, а во втором — на нечётных. Массивы нумеруются с единицы.

Формат входных данных
В первой строке входных данных лежит натуральное число n — количество элементов массива (2≤n≤500).
Во второй строке находятся n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
В первой строке выведите все элементы массива a, стоящие на чётных позициях. Во второй строке выведите все элементы массива a, стоящие на нечётных позициях.

входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
3 7
1 3

20 3
4 412 2

Ответ:
romic123
romic123
23.04.2021 13:04

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{  

   int N;

   cin >> N;

   vector<int>chet;

   vector<int>nechet;

   for (int i = 0; i < N; i++) {

       int A;

       cin >> A;

       if (i % 2 == 0)

           nechet.push_back(A);

       else

           chet.push_back(A);

   }

   for (int i = 0; i < chet.size(); i++)

       cout << chet[i] << " ";

   cout << endl;

  for (int i = 0; i < nechet.size(); i++)

      cout << nechet[i] << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?