В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
akulkaeva78
akulkaeva78
28.02.2020 12:19 •  Информатика

Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — выписать элеметы массива a с чётными номерами в начало массива b, а затем дополнить массив b нулями до размера n. Элементы массивов нумеруются с единицы.

Формат входных данных
В первой строке входных данных находится натуральное число n (1≤n≤500) — количество элементов массива.
Во второй строке лежат n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b.

входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
3 7 0 0

20 3 0 0 0

Ответ:
rminichkina
rminichkina
23.04.2021 13:00

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

int N,counter=0;

cin >> N;

vector<int> a(N, 0);

for (int i = 0; i < N; i++) {

 int b;

 cin >> b;

 if (i % 2 != 0)

  a[counter++] = b;

}

for (int i = 0; i < N; i++)

 cout << a[i]<<" ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?