В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Montyzzzz
Montyzzzz
13.12.2021 12:23 •  Информатика

Составить программу в паскале: вывести все простые числа в диапазоне от 1 до n, используя циклические конструкции.

Ответ:
sladenykaya136
sladenykaya136
24.05.2020 15:46

Program n1;
Uses CRT;
VAR n,i,k,j: integer;
begin
clrscr;
writeln('vvedite n');
Readln(n);
Writeln('Prostye chisla');
writeln;
For i:=3 to n do
begin
For j:=2 to i-1 do
If i mod j=0 then k:=k+1;
If k=0 then writeln(i);
k:=0;
end;
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?