В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
un5gao
un5gao
13.11.2022 01:26 •  Информатика

Напишите программу, на вход которой подаётся прямоугольная матрица в виде последовательности строк. После последней строки матрицы идёт строка, содержащая только строку "end" (без кавычек). Программа должна вывести результат транспонирования исходной матрицы. Элементы строк выводить через пробел.

Sample Input:
3 2
1 4
end

Sample Output:
3 1
2 4

Программу написать в Python.

Ответ:
настя7600
настя7600
20.03.2021 18:40

hi = 0

mas = []

while True:

   a = input()

   if a == 'end':

       break

   hi+=1

   mas.append([int(i) for i in a.split()])

for i in range(len(mas[0])):

   print(*[mas[g][i] for g in range(hi)])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?