В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
daniela07
daniela07
27.12.2020 17:33 •  Информатика

С++ Сверху вниз, слева направо
Даны два числа n и m. Создайте двумерный массив размером n×m и заполните его в соответствии с примером.

Входные данные

Даны два натуральных числа n и m, не превышающие 10.

Выходные данные

Выведите ответ на задачу.

Примеры
Ввод
Вывод
5 6
0 5 10 15 20 25
1 6 11 16 21 26
2 7 12 17 22 27
3 8 13 18 23 28
4 9 14 19 24 29

Ответ:
yanochka13kol
yanochka13kol
19.03.2021 16:50

о повезло повезло, пару минут назад эту же задачу решил :

#include <iostream>

#include <vector>

using namespace std;

void make_matrix(vector<vector<int>> &v){

   int n = v.size(), m = v.front().size(), cur = 0;

   for(int i = 0; i < m; i++){

       for(int j = 0; j < n; j++){

           v[j][i] = cur;

           cur++;

       }

   }

}

void print_matrix(vector<vector<int>> &v){

   int n = v.size(), m = v.front().size();

   for(int i = 0; i < n; i++){

       for(int j = 0; j < m; j++)

           cout << v[i][j] << " ";

       cout << "\n";

   }

}

signed main(){

   int n, m;

   cin >> n >> m;

   vector<vector<int>> a(n, vector<int> (m));

   make_matrix(a);

   print_matrix(a);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?