В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vlad0ss
vlad0ss
11.05.2023 03:48 •  Информатика

Напишите программу, которая на отрезке от а до в, выводит на экран все числа, оканчивающиеся на цифру три (а и в - целые числа). Оператор цикла do while

Ответ:
АняЛари
АняЛари
13.04.2021 22:23

ответ

3*2=6 хахахахахахахахахаха

0,0(0 оценок)
Ответ:
DenKovYa
DenKovYa
22.01.2024 10:15
Хорошо, давайте напишем программу, которая будет выводить на экран все числа на отрезке от a до b, которые оканчиваются на цифру 3. Используем оператор цикла do-while для решения задачи.

Первым делом, мы должны объявить две переменные типа int - a и b, которые будут представлять начало и конец отрезка, соответственно. Попросим пользователя ввести значения для a и b:

```c++
#include
using namespace std;

int main() {
int a, b;
cout << "Введите начало отрезка (число а): ";
cin >> a;
cout << "Введите конец отрезка (число b): ";
cin >> b;
```

Далее, нужно создать цикл do-while, который будет выполняться, пока a меньше или равно b. Внутри цикла, проверим, оканчивается ли текущее значение числа на 3 с помощью операции % 10, которая возвращает остаток от деления числа на 10:

```c++
do {
if (a % 10 == 3) {
cout << a << " ";
}
a++;
} while (a <= b);
```

Если остаток от деления числа a на 10 равен 3, то мы выводим число на экран с помощью оператора cout.

Затем, увеличиваем значение a на 1, чтобы перейти к следующему числу на отрезке.

Цикл продолжается, пока a меньше или равно b.

В итоге, получаем полную программу:

```c++
#include
using namespace std;

int main() {
int a, b;
cout << "Введите начало отрезка (число а): ";
cin >> a;
cout << "Введите конец отрезка (число b): ";
cin >> b;

do {
if (a % 10 == 3) {
cout << a << " ";
}
a++;
} while (a <= b);

return 0;
}
```

Теперь, если введенные числа a и b соответствуют условию задачи, программа будет выводить все числа на отрезке, которые оканчиваются на 3.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?