В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
рогозина
рогозина
26.01.2021 07:34 •  Информатика

Свобода лучше, чем несвобода. Нам всё введут, а мы выберем. Напишите программу, которая из одной строки считает:
строка (разделитель) число (необходимое количество уникальных символов) строка (для анализа)

Затем по первой строке разделить последнюю и выбрать из полученного списка только те слова, в которых уникальных символов не меньше указанного числа.

Ответ:
PuvMan
PuvMan
14.03.2021 20:10

var  

x, y: integer;

n: integer;

sum: integer;

mindif: integer;

f: text;

begin

   assign(f,'C:\27-A.txt');

   reset(f);

   readln(f, n);

   sum := 0;

   mindif := 20001;

   while not eof(f) do begin

       readln(f, x, y);

       if x > y then  

           sum := sum + x

       else  

           sum := sum + y;

       if (abs(x - y) < mindif) and (abs(x-y) mod 3 <> 0) then mindif := abs(x-y);

   end;

   if sum mod 3 <> 0 then

       writeln(sum)

   else

       writeln(sum - mindif);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?