В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arina522
arina522
03.02.2022 11:56 •  Информатика

Решить ,завтра ** тоже массивом. найти максимальный четный элемент массива и его номер при условии, что все элементы различные. составить программу

Ответ:
Варя0601
Варя0601
24.05.2020 15:09

Program n1;
Uses CRT;
Const n=10;
Var a: array[1..n] of integer;
i,max,k: integer;
begin
ClrScr;
Randomize;
For i:=1 to n do
begin
a[i]:=random(50);
write(a[i]:3);
end;
For i:=1 to n do
If a[i] mod 2=0 then
If a[i]>max then
begin
max:=a[i];
k:=i;
end;
writeln;
Writeln('Элемент ',max,' с номером ',k);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?