В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Proyd1
Proyd1
27.02.2023 23:54 •  Информатика

Напишите программу, которая вводит с клавиатуры массив из 15 элементов и находит среднее всех элементов массива:

Ответ:
Nikita67566
Nikita67566
12.03.2021 19:30

Программа работает на любое кол-во элементов.

Код:

a = [int(i) for i in input().split()]

sr = 0

for i in a:

   sr += i

print("Среднее арифметическое:", sr/len(a))

Вывод:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15                                                                                            

Среднее арифметическое: 8.0  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?