В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
victoria223
victoria223
25.05.2020 07:49 •  Информатика

1. напишите программу,чтобы найти сумму цифр заданного числа а=23451.
2.Даны три числа а,b,c. Найти наибольшее число.
3.Переведите с двоичной системы в десятичную и напишите программу перевода.
10101011 внизу 2=x внизу 10
(программа Питон)​

Ответ:
oleninaonii
oleninaonii
11.04.2021 17:00

1:

s = 0

a = int(input('Введите число: '))

while a>0:

 s += a%10

 a = a//10

print('Сумма цифр равна ', s)

2:

a = int(input('Введите a: '))

b = int(input('Введите b: '))

c = int(input('Введите c: '))

min = a

max = a

if b < min: min = b

if b > max: max = b

if c < min: min = c

if c > max: max = c

print('Минимальное из введённых: ', min)

print('Максимальное из введённых: ', max)

3:

a = input('Введите число в двоичной системе счисления: ')

s = 0

for i in enumerate(a[::-1]):

 s += int(i[1])*2**i[0]

print('В десятичной системе счисления это: ', s)

ответ: 171

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?