В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sernikovs
sernikovs
21.06.2022 06:23 •  Информатика

Как составить программу подсчета количеству делений введённого числа на 12 пока оно не станет меньше 10

Ответ:
kotia1799
kotia1799
18.06.2020 07:40
Pascal:
var count:integer;
     n:real; 
begin
  write ('N = ');
  readln(n);
  count:=0;
  while n>=10 do
    begin
      n:=n/12;
      inc(count);
    end;
  write ('Kol-vo: ',count);
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
   float n;
   int count = 0;
   cout <<"N = ";
   cin >>n;
   while (n>=10)
   {
      n/=12;
      ++count; 
   }
  cout <<"Kol-vo: " <<count <<endl;
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?