В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу на языке Python с оператора while. Преобразуйте вес, заданный в пудах (в пределах 1-50 пудов), в килограммы. Формула преобразования 1пуд =16,2 кг. Вывести на экран только целый вес в килограммах

за правильный ответ поставлю и отмечу, как лучший ответ​


Составьте программу на языке Python с оператора while. Преобразуйте вес, заданный в пудах (в предела

Ответ:
Lera246hh
Lera246hh
10.04.2021 11:51

если с одной запятой в результате то:

import math

pyd = int(input('Введите количество пудов от 1 до 50: '))

kg = (pyd*16.2)

while pyd >=1 and pyd <=50:

   kg=round(kg,2)

   print(kg,'кг')

   break

else:

   print('Вы что-то ввели не верно')

Если целое с округление (16.2 = 16,  64.8 =65)

import math

pyd = int(input('Введите количество пудов от 1 до 50: '))

kg = (pyd*16.2)

while pyd >=1 and pyd <=50:

   kg=round(kg,0)

   print(kg,'кг')

   break

else:

   print('Вы что-то ввели не верно')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?