В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Vitalikebati
Vitalikebati
14.01.2023 19:05 •  Информатика

ИВТ СОЧ Составить программу, которая в зависимости от порядкового номера месяца (1, 2, ..., 12) выводит на экран количество дней в этом месяце. Рассмотреть случай, что не високосный.

Ответ:
Finger2280
Finger2280
09.03.2021 15:40

програмка:

#include "stdafx.h" #include <iostream> #include <cstdlib>   using namespace std;   int main(int argc, _TCHAR* argv[]) {     setlocale(LC_ALL, "RUS");     cout << "Введите месяц: ";     int m;     cin >> m;       if(m == 2)     {         char ch;         cout << "Год високосный? (y/n):";         cin >> ch;         if(ch == 'y')             cout << "В этом месяце 29 дней" << endl;         else if(ch == 'n')             cout << "В этом месяце 28 дней" << endl;     }       if((m % 2))         cout << "В этом месяце 31 день." << endl;     else     {         if(!(m % 2))         {             if(m != 2)                 cout << "В этом месяце 30 дней." << endl;         }     }         system("pause");     return 0; }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?