В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
marusia20022
marusia20022
11.04.2021 23:36 •  Информатика

Составить программу на языке паскаль: s= 1-2+3-4++.

Ответ:
Keneke
Keneke
24.05.2020 14:21

var i,n,s:integer;
begin
  write('n = ');
  readln(n);
  for i:=1 to n do
    if i mod 2 = 0 then dec(s,i) else inc(s,i);
  write('S = ',s)
end.

0,0(0 оценок)
Ответ:
хХхмхХх
хХхмхХх
24.05.2020 14:21

var n,i,rez:integer;
begin
write('Введите n: ');
readln(n);
rez:=0;
for i:=1 to n do
if odd(i) then rez:=rez+i
else rez:=rez-i;
writeln('rez=',rez);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?