В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

8 класс. Питон. Задача1. Строковый метод isdigit() проверяет, состоит ли строка только из цифр. Напишите программу, которая запрашивает ввод двух целых чисел и выводит их сумму. В случае некорректного ввода программа не должна завершаться с ошибкой, а должна продолжать запрашивать числа.

Задача 2. Напишите шаблон по запросу у пользователя логина и пароля. Если логин или пароль будут введены с ошибкой, то необходимо вывести сообщение о том, что такой логин или пароль не найдены. Если логин и пароль совпадают, то вывести приветствие с указанием имени пользователя.

Ответ:
jasmin47
jasmin47
03.04.2021 15:43
1)

x,y = map(str,input().split())

while not (x.isdigit() and y.isdigit()):

   x,y = map(str,input().split())

print(int(x)+int(y))

2)

Correct_login = "maxum000"

Correct_passw = "12345"

while (True):

   login = input("Логин: ")

   passw = input("Пароль: ")

   if (login == Correct_login and passw == Correct_passw):

       print("Добро ,", login)

       break

   elif (login != Correct_login):

       print("Такого пользователя и пароля не существует.")

   elif (login == Correct_login and passw != Correct_passw):

       print("Неверный пароль, попробуйте снова.")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?