В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
9Kira9
9Kira9
15.08.2020 14:23 •  Информатика

Составить алгоритм, написать программу, которая заполняет массив из 20 данных случайными числами и делят его на два массива, в один помещает четные числа в другой нечетные. вывести исходный массив, массив четных чисел и нечетных чисел.

Ответ:
Liana250202
Liana250202
01.10.2020 07:21

var

  a,b,c:array [1..20] of integer;

  i,k,l:integer;

begin

  randomize;

  k:=1;

  l:=1; 

  writeln ('Исходный массив: '); 

  for i:=1 to 20 do

   begin

    a[i]:=random(9)+1;

    if a[i] mod 2 = 0 then

     begin

      b[k]:=a[i];

      inc(k);

     end else

      begin

       c[l]:=a[i];

       inc(l);

      end; 

    write (a[i],' ');

  end;

  k:=k-1;

  l:=l-1; 

  writeln;

  writeln ('Массив четных чисел');

  for i:=1 to k do write (b[i],' ');

  writeln;

  writeln ('Массив нечетных чисел');

  for i:=1 to l do write (c[i],' ');

  writeln;

  readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?