В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
liza2002623
liza2002623
25.09.2022 09:58 •  Информатика

Дано слово длиной не менее 8 символов написать программу которая переносит 1 букву в конец слова

Ответ:
Mrx7777
Mrx7777
17.06.2020 21:14

uses crt;
var
  s:string;p:char; i:integer;
begin
  write('Введи слово, в котором не менее 8 букв:  '); readln(s);
  if length(s)<8 then write('Вы ввели слишком короткое слово.')
  else
  begin
    p:=s[1];
    for i:=1 to length(s) do

      s[i]:=s[i+1];
      s[i]:=p;
      write(s);
  end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?