В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Liladina
Liladina
06.04.2021 04:21 •  Информатика

с задачей Python площадь треугольника ACMP №822 Площадь треугольника
По целочисленным координатам вершин треугольника (x1,y1), (x2,y2) и (x3,y3) требуется вычислить его площадь.

Входные данные
Входной файл INPUT.TXT содержит 6 целых чисел x1,y1,x2,y2,x3,y3 – координаты вершин треугольника. Все числа не превышают 106 по абсолютной величине.

Выходные данные
В выходной файл OUTPUT.TXT выведите точное значение площади заданного треугольника.

Ответ:
dasha43com
dasha43com
02.03.2021 18:40

var x1,x2,x3,y1,y2,y3,a,b,c,S,P: real;

begin

readln(x1,y1,x2,y2,x3,y3);

a:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));

b:=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));

c:=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));

P:=a+b+c;

writeln('периметр: ',P);

P:=P/2;

S:=sqrt(P*(P-a)*(P-b)*(P-c));

write('площадь: ',S);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?