В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
5Vlad2851
5Vlad2851
20.10.2021 09:43 •  Информатика

16. составить программу для вывода двух массивов, первый из которых состоит из отрицательных элементов и задаётся вручную, второй- состоит из нечётных элементов и задаётся функцией случайного выбора. 20)составить массив из 10 отрицательных чисел. вывести второй массив, состоящий из элементов певого массива, умноженных на введенное число. все в тубропаскале: )

Ответ:
JesusVl
JesusVl
17.06.2020 12:12

1)

var

a,b:array [1..10] of integer;

i:integer;

begin

for i:=1 to 10 do begin

repeat 

write ('A[',i,'] = ');readln(a[i]);

if a[i]>0 then writeln ('Error!'); 

until a[i]<0; 

end;

writeln ('First massiv: ');

for i:=1 to 10 do write (a[i]:4);

writeln; 

writeln ('Second massiv: ');

i:=1; 

repeat

b[i]:=random(38)+3;

if odd(b[i])=true then i:=i+1; 

until i>10;

for i:=1 to 10 do write (b[i]:4);

writeln;

readln;

end.

2)

var

a,b:array [1..10] of integer;

i,k:integer;

begin

randomize;

for i:=1 to 10 do begin

a[i]:=random(15)-15;

write (a[i]:4);

end;

writeln; 

write ('Number: ');readln(k);

for i:=1 to 10 do begin

b[i]:=a[i]*k;

write (b[i]:4);

end;

writeln;

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?