В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
2kkdKristina
2kkdKristina
25.01.2020 02:15 •  Информатика

написать программу на C++ Сумма больших

С клавиатуры вводится несколько чисел.

Найдите сумму чисел, превышающих 4.

Формат ввода
В первой строке вводится количество чисел n. 0 ≤ n ≤ 1000.

В следующей строке вводятся подряд n чисел ai через пробел. 0 ≤ ai ≤ 1000.

Формат вывода
Выведите сумму чисел, больших 4. Если таких чисел нет, выведите 0.

Пример
Ввод Вывод
4 5
2 5 3 4

Ответ:
robotkiborg
robotkiborg
28.03.2021 23:53

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

int n, x = 0;

int *a = new int[n];

printf("Enter the number of digits\n");

cin >> n;

printf("Enter numbers\n");

for(int i = 0; i < n; ++i)

{

 cin >> a[i];

 if(a[i] > 4)

 x+=a[i];

}

printf("%d",x);

delete [] a;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?