В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Оленка124683
Оленка124683
11.01.2021 12:04 •  Информатика

Всреде turbo pascal написать программу: используя одномерный массив из 10 чисел найти сумму

Ответ:
Пикантные
Пикантные
01.10.2020 06:05

Проверено на Паскале АВС:

 

Program byalodenis;
uses crt;
const n=10;
var
  e:array[1..n] of integer;
  min,max,i: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Элементы массива:');
  randomize;
  e[1]:=random(100)-50;
  write (e[1]:5);
  max:=e[1];
  min:=e[1];
  for i:=2 to n do
    begin
      e[i]:=random(100)-50;
      write (e[i]:5);
      if e[i]>max then
        max:=e[i];
      if e[i]<min then
        min:=e[i];
    end;
  writeln();
  writeln('Сумма максимального и минимального элементов равна ',max+min);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?