В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sofialesiuk
sofialesiuk
07.05.2021 21:50 •  Информатика

Как это ( в паскале.) в магазине трилайн периодически бывают скидки. составить программу, которая запрашивает цену покупаемого товара и его количество, информацию о скидке (в процентах, если скидки нет, то ввести 0%). на печать должна выводиться сумма к оплате.

Ответ:
pahan250
pahan250
17.06.2020 09:28

Поверено на Паскале АВС

 

Program PSM;
uses crt;
var
  cena, summa:real;
  kwo,skid : integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln;  writeln;
  writeln('++');
  writeln('|             Приветствуем вас в магазине ТРИЛАЙН!              |');
  writeln('++');
  writeln('|       Введите необходимую информацию ниже:       |');
  writeln('++');
  write('       Цена товара:  '); readln(cena);
  write('       Количество единиц товара:  '); readln(kwo);
  write('       Размер скидки в % (0 - если скидки нет) '); readln(skid);
  writeln('++');
  writeln('|                                                               |');
  writeln('|                 Сумма к оплате: ',cena*kwo*(1-skid/100):10:2,'                    |');
  writeln('|                                                               |');
  writeln('++');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?