В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Vymnuk228
Vymnuk228
23.01.2020 09:31 •  Информатика

Требуется написать программу при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10 в девятой степени, и выводится произведение цифр этого числа.

Ответ:
Kazudon
Kazudon
17.06.2020 02:40

uses crt;

var p,n:integer;
begin
p:=1;
write('N=');
read(n);
while n>0 do begin
p:=p*(n mod 10);
n:=n div 10;
end;
writeln('p=',p);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?