В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tanya3104
tanya3104
02.02.2023 20:28 •  Информатика

Исправить ошибки и написать блок-схему. : имеется массив а из n произвольных чисел, среди которых есть положительные, отрицательные и равные нулю. используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных. листинг программы: program massiv; const n=10; var a: array [1..4] of integer; i, c, c2, c3: integer; begin for i=1 to n do begin readln (a[i]); if (a[i]=0 then inc(c) else if ([ai]< 0) then inc(c2) else inc (c3); end; writeln (`нулевые: `,c); writeln (`отрицательные: `,c2); writeln (`положительные: `,c3); end.

Ответ:
SergeSaenko
SergeSaenko
16.06.2020 22:48

uses crt;

var i,d,o,n,m:integer;
a:array[1..100] of integer;
begin
readln(n);
randomize;
for i:=1 to n do a[i]:=random(101)-50;
for i:=1 to n do begin
if a[i] < 0 then o:=o+a[i]
else inc(d);
if a[i] = 0 then inc(m);
end;
for i:=1 to n do write(a[i],' ');
writeln;
writeln('null = ',m);
writeln('otr = ',o);
writeln('pol = ',d);
readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?