В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
2458k
2458k
19.04.2022 08:25 •  Информатика

Дан массив a из n элементов. Требуется найти минимум массива и вставить его в начало, порядок других элементов сохранить. Если минимальных элементов несколько, переместить первый найденный минимальный элемент массива.

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) — размер массива. Во второй строке вводятся n элементов массива через пробел. Все элементы не превосходят по модулю 100.
Формат выходных данных
Необxодимо вывести измененный массив.
входные данные
5
4 5 3 1 2
выходные данные
1 4 5 3 2

Ответ:
Егор02121
Егор02121
18.03.2021 01:52

Объяснение:

#include <iostream>

using namespace std;

int main()

{

int a[5];

int k;

int i;

setlocale(LC_ALL, "Russian");  

cout << "введите через пробел пять элементов массива a:";

cin>>a[1]>>a[2]>> a[3]>>a[4]>>a[5];

cout <<"Входные данные:";

cout << a[1]<<" "<< a[2]<<" "<< a[3]<<" "<<a[4]<<" "<<a[5]<<endl;

int min=a[1];

for (int i=2; i<=5; i++)

{

if (min>a[i])

 {

 min=a[i];

 k=i;

}

}

cout<<"Минимальный элемент массива:";

cout << min<<endl;

int x=a[k];

for ( i=k; i>1; i--)

{ a[i]=a[i-1];

}

if ( i<=0)

a[1]=min;

else

a[1]=x;

cout <<"Выходные данные:";

cout << a[1]<<" "<< a[2]<<" "<< a[3]<<" "<<a[4]<<" "<<a[5]<<endl;

return 0;

}


Дан массив a из n элементов. Требуется найти минимум массива и вставить его в начало, порядок других
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?