В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lenawer
lenawer
28.02.2021 15:02 •  Информатика

Написать программу Pascal для нахождения наибольшей цифры целого положительного числа. Длина числа до 9 цифр. ​

Ответ:
Марат991
Марат991
17.03.2021 20:20

var

 a: string;

 b: array[1..9]of integer;

 sort: boolean;

 max, k: integer;

begin

 Readln(a);

 for var i := 1 to Length(a) do

   b[i] := strtoint(a[i]);

 sort := false;

 while sort = false do

 begin

   sort := true;

   k += 1;

   for var i := 1 to Length(a)-1 do

   begin

     if a[i] < a[i+1] then

     begin

       sort := false;

       var value2 := a[i];

       a[i] := a[i+1];

       a[i+1] := value2;

     end;

   end;

 end;

 write(a[1]);

end.

Программа написана на PascalABC.net

на free pascal или turbo pascal она может не работать

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?