В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
daryabatova
daryabatova
18.10.2022 07:25 •  Информатика

Дан массив a из n натуральных чисел. Требуется вывести все элементы массива, являющиеся двузначными числами.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны натуральные числа ai (ai≤103) — элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все числа, являющиеся двузначными, в том же порядке, в каком они расположены во входном файле.

входные данные
4
100 20 4 318

10
42 7 59 7 212 47 777 66 89 6
выходные данные
20

42 59 47 66 89

Ответ:
emilyblack80
emilyblack80
14.03.2021 22:20

#include <iostream>

#include <cmath>

using namespace std;

signed main(){

   int n,x;

   cin >> n;

   while(n--){

       cin >> x;

       int X = x, cnt = 0;

       while(X > 0){

           X /= 10;

           cnt++;

       }

       if(cnt == 2)

           cout << x << " ";

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?