В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
guast1
guast1
13.04.2020 03:57 •  Информатика

Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все четные числа, в том же порядке, в каком они расположены во входном файле.
входные данные
4
100 -20 4 318

10
-42 70 59 76 21 47 77 66 89 60
выходные данные
100 -20 4 318

-42 70 76 66 60

Ответ:
Fox1114
Fox1114
14.03.2021 21:59

#include <iostream>

using namespace std;

signed main(){

   int n, x;

   cin >> n;

   while(n--){

       cin >> x;

       if(x % 2 == 0)

           cout << x << " ";

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?