В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Проверочная работа. 1)Задача
Написать программу, подсчитывающую количество четных и нечетных цифр в числе.

2)Задача
Вводится число. Преобразовать его в другое число, цифры которого будут следовать в обратном порядке по сравнению с введенным числом.

3)Задача
Вывести на экран ряд чисел Фибоначчи, состоящий из n элементов.​

Ответ:
shlykhta95
shlykhta95
12.02.2021 12:10

1)

var

a: integer;

even,odd: byte;

begin

readln(a);

even := 0;

odd := 0;

while a > 0 do begin

 if (a mod 2) = 0 then

  even := even + 1

 else

  odd := odd + 1;

 a := a div 10;

end;

writeln('even: ', even);

writeln('odd: ', odd);

end.

2)

var

   n, m: longint;

   a: byte;

begin

   readln(n);

   m := 0;

   while n>0 do begin

       a := n mod 10;

       n := n div 10;

       m := m*10 + a;

   end;

   writeln(m);

readln;

end.

3)

var

   a,b,c,i,n: integer;

begin

   write('n = ');

   readln(n);

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;

readln

end.

Объяснение:


Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?