В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
10203040502017
10203040502017
18.02.2023 16:44 •  Информатика

Среди заданных целых чисел A,B,C,D есть хотя бы два четных? Напишите программу на pascal ABC

Ответ:
IamGroot1
IamGroot1
13.03.2021 00:13

var

 a, b, c, d, kol: integer;

begin

   write('Введите четыре числа A, B, C и D через пробел: ');

   readln(a, b, c, d);

   if a mod 2 = 0 then inc(kol);

   if b mod 2 = 0 then inc(kol);

   if c mod 2 = 0 then inc(kol);

   if d mod 2 = 0 then inc(kol);

   if kol >= 2 then writeln('Среди введенных чисел есть два или более четных числа')

     else writeln('Среди введенных чисел менее двух четных');

end.

Объяснение:

Другой вариант (покороче):

var

 a, b, c, d: integer;

begin

   write('Введите четыре числа A, B, C и D через пробел: ');

   readln(a, b, c, d);

   if ((a mod 2) + (b mod 2) + (c mod 2) + (d mod 2)) <= 2

       then writeln('Среди введенных чисел есть два или более четных числа')

       else writeln('Среди введенных чисел менее двух четных');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?