В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aazzziizz
aazzziizz
04.08.2022 04:48 •  Информатика

1 написать программу удвоения меньшего из двух неравных чисел 2 написать программу увеличить число х на один если оно четное уменьшит на 1 если нечетное

Ответ:
heyguys112
heyguys112
12.03.2021 10:45

1.

a, b = 1, 2

if a < b:

a *= 2

else:

b *= 2

2.

x = 43 # Любое число

if x%2 == 0:

x += 1

else:

x -= 1

0,0(0 оценок)
Ответ:
andreweeoneoff
andreweeoneoff
12.03.2021 10:45

1)

var a,b:integer;

begin

 writeln('Введите два числа:');

 readln(a,b);

 if a>b then

   b:=b*2

 else begin

 if b>a then

   a:=a*2;

end;

writeln('Первое число =',' ',a);

 writeln('Второе число =',' ',b);

end.

2)

var x:integer;

begin

 writeln('Задайте число:');

 readln(x);

 begin

 if (x mod 2=0) then

  inc(x)

 else

  dec(x);

   end;

writeln(x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?