В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mariamshakhram
mariamshakhram
17.08.2020 06:40 •  Информатика

Язык Pascal . Напишите программу, которая позволяет вводить с клавиатуры натуральное 3- значное число N и выполняет с ним следующие операции:
a) выводит на экран его цифры - по одной на каждой строке
b) формирует число N1, образованное перестановкой цифр исходного числа в
обратном порядке, например, из числа 123 должно получиться число 321,
с) формирует число N2, полученное перестановкой цифр десятков и единиц
d) формирует число N3, полученное перестановкой цифр сотен и десятков,
е) формирует число N4, полученное приписыванием цифры единиц в качестве
цифры тысяч (например, число 137 должно преобразоваться в 7137),
f) формирует число N5, полученное приписыванием цифры единиц в качестве
цифры тысяч и цифры сотен в качестве единиц (например, 137 должно
преобразоваться в 71371)
Все пункты задания 3 должны быть реализованы в одной программе.​

Ответ:
PAVELBOR
PAVELBOR
11.03.2021 11:01

program z1;

var n,c,d,e,n1,n2,n3,n4,n5:integer;

begin

write('n (99<n<1000) = ');

readln(n);

c:=n div 100;

d:=n div 10 mod 10;

e:=n mod 10;

writeln(c);

writeln(d);

writeln(e);

n1:=e*100+d*10+c;

writeln(n1);

n2:=c*100+e*10+d;

writeln(n2);

n3:=d*100+c*10+e;

writeln(n3);

n4:=e*1000+n;

writeln(n4);

n5:=e*10000+n*10+c;

writeln(n5)

end.

Объяснение:

Вводим число

Разбиваем на отдельные цифры сотен (1 цифра), десятков (2 цифра) и единиц (3 цифра)

Выводим на экран и формируем числа согласно условиям и примерам

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?