В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
schvarzengold100
schvarzengold100
08.12.2021 22:18 •  Информатика

Напишите программу на "python" которая генерирует случайный пример на сложение двух чисел, например "Сколько будет 17 + 13?"

Программа предлагает пользователю ввести решение примера.

Если решение введено верно, программа выводит "Верно"

Если решение неверное - выводит "Неверно"

Далее программа предлагает продолжить решать примеры, если пользователь вводит

с клавиатуры слово stop, программа останавливается, если нажимает Enter -

программа предлагает на решение ещё один пример.

"Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания"

Кроме того, если количество решенных примеров больше 5, то программа заканчивает выполнение

выводя "Ты хорошо справился, думаю на сегодня хватит"

При завершении программы должен выводиться результат - количество правильно решенных

примеров. "Количество верных ответов: 4"

Если количество верных решений больше 5, программа выводит "Молодец"

Если меньше: "Потренеруйся ещё"​

Ответ:
Кек11111111118
Кек11111111118
11.03.2021 02:49

from random import randint

class G:

def __init__(self):

 self.wins = 0

def menu(self):

 print("stop - для остановки решения\nEnter продолжение.")

 while 1:

  if self.wins > 5:

   print("Ты хорошо справился, думаю на сегодня хватит")

   G.result(self)

   break

  a = input(": ")

  if a == "stop":

   G.result(self)

   break

  elif a == "":

   G.game(self)

  else: pass

def game(self):

 n1,n2 = randint(1,100),randint(1,100)  # примеры от и до

 print(f"Сколько будет: {n1} + {n2}?")

 if int(input("ответ: ")) == n1+n2:

  print("Верно")

  self.wins += 1

 else:

  print("Неверно")

 if self.wins != 5+1:

  print("Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания")

def result(self):

 print("игра остановлена")

 print(f"Количество верных ответов: {self.wins}")

 if self.wins > 5:

  print("Молодец!")

 else:

  print("Потренируйся ещё")

a = G()

a.menu()


Напишите программу на python которая генерирует случайный пример на сложение двух чисел, например
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?