В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Yascher
Yascher
21.04.2020 07:19 •  Информатика

РЕШИТЬ Напишите программу, которая считывает последовательность из 10 целых чисел и определяет является ли каждое из них четным или нет.

Формат входных данных

На вход программе подаются 10 целых чисел, каждое на отдельной строке.

Формат выходных данных

Программа должна вывести строку «YES», если все числа четные и «NO» в ином случае.

Sample Input 1:

2

4

6

8

10

12

14

16

18

20

Sample Output 1:

YES

Sample Input 2:

1

2

3

4

5

6

7

8

9

10

Sample Output 2:

NO

РЕШИТЕ ОЧЕНЬ НАДО ОЧЕНЬ А ТО МНЕ КАПЕЦ ОТ РОДОКОВ

Ответ:
Ангелина8394
Ангелина8394
09.03.2021 17:48

result = 'YES'

for i in range (0,10):

 if (int(input()))%2 != 0: result = 'NO'

print(result)

Или можно ещё так, чтобы ошибки входных данных отлавливать:

i = 0

result = 'YES'

while i<10:

 try:

   if (int(input()))%2 != 0: result = 'NO'

   i+=1

 except ValueError:

   print('Неверный формат входных данных. Вводите целое число.')

print(result)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?