В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ElviraNice
ElviraNice
01.06.2020 09:59 •  Информатика

очень Напишите программу на языке Паскаль для решения задачи:
1. Запросить от пользователя трехзначное натуральное число.
2. Разбить число на цифры.
3. Найти сумму и произведение цифр числа.
4. Вывести на экран ответ "Больше", если сумма больше произведения,
ответ "Меньше" , если сумма меньше произведения
и "Равно", если сумма равна произведению.

Ответ:
Lency
Lency
04.02.2021 16:10

var a,c1,c2,c3,p,s:integer;

begin

 p:=1;

 read(a);

 c1:=a mod 10;

 a:= a div 10;

 c2:=a mod 10;

 a:= a div 10;

  c2:=a mod 10;

  p:=c1*c2*c3;

  s:=c1+c2+c3;

  if s>p then writeln('больше') else if   s<p then writeln('меньше') else writeln('равно')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?