В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rubaqlo
rubaqlo
09.05.2021 13:07 •  Информатика

Составьте программу,заменяющую из двух данных чисел большее число удвоенным произведением,а меньшее-полусуммой этих чисел.

Ответ:
Rostik9999
Rostik9999
16.06.2020 00:54

program 1;

 

uses crt;

 

var a,b:real;

begin  clrscr;

 

write('vvedite a '); readln(a);

write('vvedite b '); readln(b);

 

If a>b then begin a:=abs(2*a*b);                   b:=abs((a+b)/2);                   end else begin a:=abs((a+b)/2);                                  b:=abs(2*a*b);                                  end; writeln('a= ',a:0:2,' ','b= ',b:0:2); repeat until KeyPressed; end.

0,0(0 оценок)
Ответ:
ElviraNice
ElviraNice
16.06.2020 00:54

ну а вдруг числа отрицатильные)) а abs делает их положительными)


var a,b:real;
begin cls;

write('vvedite a '); readln(a);
write('vvedite b '); readln(b);

If a>b then
begin
a:=2*a*b;
b:=(a+b)/2;
end
else
begin
a:=(a+b)/2;
b:=2*a*b;
end; writeln('a= ',a:0:2,' ','b= ',b:0:2);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?