В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
10YANA22
10YANA22
08.05.2021 21:05 •  Информатика

От Задание из ЕГЭ по информатике. Написать программу, которая ищет в файле цифру, встречающуюся чаще всего.​

Ответ:
Sergey15211
Sergey15211
04.03.2021 20:20

На Питоне:

path = 'F:/file.txt'

with open(path, 'r', encoding='utf-8') as f:

   data = f.read()

   f.close

a = [0 for i in range(10)]

for char in data:

   if char == '0': a[0]+=1

   elif char == '1': a[1]+=1

   elif char == '2': a[2]+=1

   elif char == '3': a[3]+=1

   elif char == '4': a[4]+=1

   elif char == '5': a[5]+=1

   elif char == '6': a[6]+=1

   elif char == '7': a[7]+=1

   elif char == '8': a[8]+=1

   elif char == '9': a[9]+=1

print(a)

digit = max(a)

if digit > 0:

   print(f'Самая часто встречающаяся цифра в файле {a.index(digit)}. Она встречается {digit} раз.')

else:

   print('В файле нет цифр.')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?