В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Russiangirl27
Russiangirl27
17.09.2021 00:37 •  Информатика

Информатика Дан треугольник со сторонами a b c, составить программу в ПАСКАЛЕ для нахождения периметра, площади и высот Ha Hb Hc треугольника

Ответ:
gamzat370587
gamzat370587
03.03.2021 00:53

program HomeWork;

var a,b,c,P,Pp,S,Ha,Hb,Hc:real;

begin

   write('Введите стороны треугольника a, b и c (числа через пробел): '); readln(a,b,c);

   P:=a+b+c;

   Pp:=P/2;

   Ha:=2*sqrt(abs(Pp*(Pp-a)*(Pp-b)*(Pp-c)))/a;

   Hb:=2*sqrt(abs(Pp*(Pp-a)*(Pp-b)*(Pp-c)))/b;

   Hc:=2*sqrt(abs(Pp*(Pp-a)*(Pp-b)*(Pp-c)))/c;

   S:=Hc*c/2;

   writeln('Параметры треугольника со сторонами a=', a:0:3, ', b=', b:0:3, ' и c=', c:0:3, ':');

   writeln('Периметр: ', P:0:3);

   writeln('Площадь: ', S:0:3);

   if Pp-a >= 0 then writeln('Высота, опущенная на сторону a: ', Ha:0:3)

   else writeln('Высота, опущенная на сторону a (находится вне треугольника): ', Ha:0:3);

   if Pp-b >= 0 then writeln('Высота, опущенная на сторону b: ', Hb:0:3)

   else writeln('Высота, опущенная на сторону b (находится вне треугольника): ', Hb:0:3);

   if Pp-c >= 0 then writeln('Высота, опущенная на сторону c: ', Hc:0:3)

   else writeln('Высота, опущенная на сторону c (находится вне треугольника): ', Hc:0:3)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?