В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kirilleven
kirilleven
29.10.2021 20:54 •  Информатика

Дан двумерный массив размерностью n*m. заменить все отрицательные элементы на противоположные.( составить программу для паскаля).

Ответ:
LOL2202
LOL2202
15.06.2020 13:43

const NN=50;
var
a:array [1..NN,1..NN] of integer;
i,j,m,n:integer;
begin
  write('Введите n: ');
  readln(n);
  write('Введите m: ');
  readln(m);
  for i:= 1 to n do
    for j:= 1 to m do
      readln(a[i,j]);
 for i:= 1 to n do
    for j:= 1 to m do
      if a[i,j]<0 then a[i,j]:=abs(a[i,j]);
 for i:= 1 to n do
 begin
    for j:= 1 to m do
      write(a[i,j],' ');
    writeln;
 end;
 end.

0,0(0 оценок)
Ответ:
Inal04102004
Inal04102004
15.06.2020 13:43

Program a1;
Uses crt;
const n=8;
m=8;
Var a:array[1..n,1..m] of integer;
i,j:byte;
Begin
Writeln('Исходная матрица');
For i:=1 to n do
begin
Writeln;
For j:= 1 to m do
begin
a[i,j]:=random(101)-50;
Write(a[i,j],' ');
end;
end;

Writeln;
Writeln('Отредактированная матрица');
For i:=1 to n do
begin
Writeln;
For j:= 1 to m do
begin
If a[i,j]<0 then a[i,j]:=abs(a[i,j]);
Write(a[i,j],' ');
end;
end;
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?